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1. CƠ SỞ LÝ THUYẾT 

Phần mềm được lập trình tính toán dựa trên cơ sở các quy định trong TCVN 2737:1995 và TCXD 

229:1999 

Thông tin về địa danh công trình, phân vùng áp lực gió được lấy theo Quy chuẩn kỹ thuật quốc gia 

về số liệu điều kiện tự nhiên dùng trong công trình xây dựng (QCVN 02:2009/BXD) 
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2. CỬA SỔ KHỞI ĐỘNG NHANH 

Cửa sổ khởi động nhanh xuất hiện ngay khi bạn khởi động xong phần mềm, cửa sổ này cho phép bạn 

thực hiện các thao tác như: thiết lập thông tin công trình bằng cách nhập thông số hoặc bằng file 

MDB xuất ra từ phần mềm Etabs, hay mở file đã lưu bằng cách click các nút lệnh tương ứng, hoặc 

bạn có thể bỏ qua cửa sổ này bằng cách click Chọn sau 

 
 

 

  

http://wefly-str.com/
http://www.ketcausoft.com/


WDL - PHẦN MỀM TÍNH TOÁN TẢI TRỌNG GIÓ  

 

Công ty TNHH Kết Cấu WEFLY - http://wefly-str.com 
KetcauSoft - Phát triển phần mềm thiết kế kết cấu Việt Nam - http://www.ketcausoft.com 

 
4 

 

3. QUY TRÌNH TÍNH TOÁN 

3.1. Các bước tính toán tải trọng gió sử dụng phần mềm WDL 

Bước 1: Thiết lập thông tin về địa điểm xây dựng 

Bước 2: Thiết lập phương pháp tính toán thành phần tĩnh 

Bước 3: Thiết lập thông tin kết cấu trên mái 

Bước 4: Thiết lập thông tin công trình 

Bước 5: Tính toán 

Bước 6: Xuất kết quả tính toán 

 

3.2. Các phương pháp thiết lập thông tin công trình 

Thông tin công trình bao gồm: 

 Số lượng và chiều cao các tầng 

 Kích thước mặt bằng 

 Cao độ của mặt đất so với mặt móng 

Tùy thuộc tính chất công trình, phần mềm cung cấp 2 phương pháp thiết lập thông tin công trình như 

sau: 

 Tạo thông tin công trình bằng cách nhập thông số. Áp dụng cho các công trình thấp tầng, 

không cần xét đến thành phần động của tải trọng Gió 

 Tạo thông tin công trình từ phần mềm Etabs. Áp dụng cho các công trình có xét đến thành 

phần động của tải trọng Gió 
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4. THIẾT LẬP THÔNG TIN VỀ ĐỊA ĐIỂM XÂY DỰNG 

Thông tin về địa điểm xây dựng là căn cứ để phần mềm xác định các thông số như: giá trị tiêu chuẩn 

của áp lực gió, mức độ ảnh hưởng của gió bão, giá trị tần số giới hạn fL 

Khu vực nhập thông tin tải trọng ở góc phía trên bên trái của phần mềm. Người dùng tiến hành chọn 

các thông tin danh sách thả xuống: 

 Thông tin về địa danh bao gồm tỉnh thành, quận huyện được lấy theo thông tin của công trình 

cần tính toán 

 Dạng địa hình lấy theo hướng dẫn tại mục 6.5 của TCVN 2737:1995, ở đây lưu ý 2 dạng địa 

hình phổ biến là: thành phố (dạng địa hình C) và khu vực ven biển (dạng địa hình A) 

 Hệ số an toàn: phụ thuộc vào cấp công trình. Theo QCVN 02:2009/BXD, công trình cấp 1 có 

hệ số an toàn (hệ số độ tin cậy) bằng 1.37 (ứng với công trình có tuổi thọ trên 100 năm), các 

cấp thấp hơn sử dụng hệ số an toàn bằng 1.2.  

 
 

 

Phần mềm sẽ tự thiết lập hệ số an toàn khi bạn nhập thông tin số tầng của công trình 
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5. THIẾT LẬP PHƯƠNG PHÁP TÍNH TOÁN THÀNH PHẦN TĨNH 

Các thiết lập về phương pháp tính toán thành phần tĩnh bao gồm: cách tính chiều cao đón gió và cách 

quy đổi tải trọng 

5.1. Cách tính chiều cao đón gió 

Có 2 phương pháp xác định chiều cao đón gió bao gồm: 

 Chiều cao đón gió của 1 sàn được xác định từ 1/2 chiều cao của tầng phía trên và tầng phía 

dưới sàn đó 

 Chiều cao đón gió của 1 sàn được xác định bằng chiều cao của tầng phía dưới sàn đó 

  

Chiều cao đón gió được xác định bằng 1/2 

chiều cao tầng trên và tầng dưới 

Chiều cao đón gió được xác định bằng chiều cao 

tầng dưới 

 

5.2. Cách quy đổi tải trọng 

Có 2 phương pháp quy đổi tải trọng bao gồm: 

 Quy đổi thành tải trọng tập trình (gán vào Diaphragm), có thể áp dụng cho tất cả các trường 

hợp 

 Quy đổi thành tải phân bố (gán vào dầm biên), chỉ áp dụng cho trường hợp không phải tính 

toán thành phần động 
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6. THIẾT LẬP THÔNG TIN KẾT CẤU TRÊN MÁI 

Chức năng này cho phép người dùng tính toán tải trọng gió tác dụng lên các phần kết cấu trên mái và 

cộng vào phần tải trọng tác dụng lên sàn mái. 

Các kết cấu trên mái chính là các tường bo mái, tường thu hồi, mái dốc hoặc mái tôn. 

Bạn có thể thiết lập thông tin về kết cấu trên mái bằng cách click vào dòng chữ hiển thị thông tin 

 

 

Cửa sổ Kết cấu trên mái cho phép bạn thiết lập các thông tin như chiều cao và góc nghiêng của kết 

cấu trên mái 

 

 

Hệ số khí động của mái nghiêng được tra theo sơ đồ 2 trong Bảng 6 của TCVN 2737:1995; tải trọng 

mái nghiêng được tính toán và thành phần nằm ngang của nó được sử dụng để cộng thêm vào tải 

trọng tác dụng lên phần mái. 

Do bảng 6 chỉ đề cập đến mái có góc nghiêng < 60 độ; nên các mái có góc nghiêng > 60 độ sẽ được 

tính toán như các tường thẳng đứng (hệ số khí động cho gió đẩy và gió hút lần lượt là 0.8 và 0.6). 

 

Kết quả tính toán thành phần nằm ngang của tải trọng gió tác dụng lên mái nghiêng trong 

trường hợp góc nghiêng bé (< 40 độ) cho thấy giá trị không đáng kể, nguyên nhân là với góc 

nghiêng < 40 độ tác dụng của tải trọng gió thường là gió bốc (c < 0) có hướng ngược chiều 

nhau ở 2 phía của mái dốc và thường là triệt tiêu lẫn nhau theo phương ngang. 
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7. THIẾT LẬP THÔNG TIN CÔNG TRÌNH 

7.1. Thiết lập thông tin công trình bằng cách nhập thông số 

Phương pháp này áp dụng cho các công trình không cần tính toán thành phần động của tải trọng gió 

Chọn nút lệnh tương ứng trong cửa sổ khởi động nhanh, hoặc click Nhập thông số trên thanh công 

cụ 

 

 

Cửa sổ Nhập thông số công trình cho phép người dùng nhập 2 thông tin cơ bản là số tầng và chiều 

cao tầng. Trong ô chiều cao tầng, bạn nhập chiều cao của tầng điển hình; bạn có thể thay đổi chiều 

cao của tầng khác ở các bước sau. Nhập các thông tin và click Hoàn thành 

 

 

Trong giao diện chính của phần mềm, bạn có thể thay đổi chiều cao tầng bằng cách nhập trực tiếp giá 

trị vào các ô chiều cao (cột Ht) 

 

 

Đối với phương pháp nhập thông số và khi quy đổi tải trọng thành lực tập trung để gán vào 

diaphragm, bạn phải nhập thêm thông tin về các kích thước Lx và Ly của mặt bằng các tầng. Trong 
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trường hợp quy đổi thành tải phân bố gán lên dầm biên, bạn không cần nhập các thông tin Lx và Ly 

do không cùng đến các thông tin này. 

 

Quy ước về kích thước Lx và Ly của mặt bằng 

 

 

Với mục đích hỗ trợ nhập nhanh số liệu, phần mềm sẽ tự động lấy kích thước mặt bằng các 

tầng dưới theo giá trị mà bạn nhập cho tầng trên nó. Do đó bạn hãy nhập thông tin kích 

thước mặt bằng theo thứ tự các tầng từ trên xuống dưới 

 

7.2. Thiết lập thông tin công trình từ mô hình Etabs 

Phương pháp này áp dụng cho các công trình cần tính toán thành phần động của tải trọng gió. 

Phần mềm sẽ tự động nhập thông tin công trình bao gồm số tầng, chiều cao các tầng, kích thước các 

mặt bằng, và các thông tin về dao động của công trình để phục vụ việc tính toán thành phần động của 

tải trọng gió. 

Trước đó, bạn cần xuất dữ liệu từ phần mềm Etabs sang file MDB, mô hình cần được phân tích dao 

động trước khi xuất dữ liệu. 

7.2.1. Xuất dữ liệu từ Etabs  

7.2.1.1. Xuất dữ liệu từ Etabs 9.7 

Sau khi phân tích mô hình, click File > Export > Save Input/Output as Access Database File  

Trong cửa sổ Choose Tables, chọn các bảng sau đây và click OK 

 Building Data 

 Point Assignments 

 Modal Information 

 Building Output 
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7.2.1.2. Xuất dữ liệu từ Etabs 2013 trở lên 

Sau khi phân tích mô hình, click File > Export > ETABS Tables to Access 

Trong cửa sổ Choose Tables, click chuột phải vào dòng Tables, chọn Modify Options 

 

 

Trong cửa sổ Tables Obtions, mục Load Cases chọn Modal, mục Load Combinations chọn None, 

sau đó click OK 
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Quay lại cửa sổ Choose Tables, chọn các bảng sau đây và click OK: 

 Project Settings 

 Structure Layout 

 Assignments 

 Displacements 

 Modal Results 

 Structure Results 

 

 

7.2.2. Lưu ý khi xuất file MDB 

Etabs thường mặc định chỉ xuất dữ liệu liên quan đến đối tượng đang được chọn, do đó nếu bạn vô 

tình chọn một đối tượng nào đó trước khi xuất dữ liệu, ví dụ chỉ đơn giản là bạn lỡ click vào một 

Point, thì file MDB được xuất ra chỉ chứa dữ liệu của duy nhất đối tượng đó. Đây chính là nguyên 

nhân chủ yếu gây nên việc các phần mềm của KetcauSoft thông báo về việc đọc dữ liệu không thành 

công hoặc báo lỗi khi đọc dữ liệu từ file MDB 

Với lưu ý đó, bạn hãy luôn chắc chắn rằng mình đã không chọn bất kỳ đối tượng nào trước khi xuất 

dữ liệu, hoặc bạn hãy chủ động bỏ chọn toàn bộ trước khi thực hiện xuất dữ liệu. Để bỏ chọn toàn 

bộ, bạn có thể click vào nút lệnh có ký hiệu là Clr ở thanh công cụ góc phía dưới bên trái của phần 

mềm Etabs, hoặc click menu Select > Clear Selection 

Bạn cũng có thể dễ dàng kiểm tra xem mình có đang chọn một đối tượng nào đó không bằng việc 

quan sát nút lệnh Clr trên thanh công cụ ở góc phía dưới bên trái phần mềm. Ở hình ảnh phía dưới, 

trong hình bên trái bạn có thể thấy rằng nút lệnh Clr đang có hiệu lực, chữ trên nút lệnh có màu đen, 

chứng tỏ bạn đang chọn một đối tượng nào đó (tuy rằng việc xác định việc bạn đang chọn đối tượng 
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nào là rất khó). Để bỏ chọn, bạn click nút lệnh Clr, lập tức nút lệnh này sẽ không còn hiệu lực, chữ 

trên nút lệnh chuyển sang màu xám như hình bên phải 

 

 

7.2.3. Nhập dữ liệu vào phần mềm WDL 

Để nhập dữ liệu vào phần mềm WDL từ file MDB, chọn nút lệnh tương ứng trong cửa sổ khởi động 

nhanh, hoặc click Mở file MDB trên thanh công cụ 

 

 

Trong cửa sổ Chọn file MDB, lần lượt thực hiện các bước: 

 Trong mục Nguồn dữ liệu, chọn phiên bản Etabs tương ứng 

 Chọn kiểu mô hình đã phân tích; sau đó click vào nút lệnh bên cạnh để chọn file. Đối với mô 

hình phân tích phẳng, bạn phải chọn 2 file tương ứng với kết quả phân tích theo 2 phương 

Sau đó click Hoàn thành 
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Cửa sổ Set Mode xuất hiện cho phép bạn chỉ định các dạng dao động theo các phương. Trong cửa sổ 

này: 

 Cột Mode ID là liệt kê thứ tự các Mode xuất ra từ Etabs, số lượng các dạng dao động được 

chỉ định khi bạn thiết lập phân tích dao động trong Etabs 

 Cột T và f lần lượt là Chu kỳ và Tần số ứng với các dạng dao động 

 Cột Mass X và Mass Y lần lượt là khối lượng tham gia dao động theo các phương 

 Cột ID X và ID Y lần lượt là nhận dạng dao động của 1 Mode theo các phương. Phần mềm 

nhận dạng dao động thông qua chuyển dịch theo từng phương (Ux và Uy). Nếu chuyển dịch 

không đổi dấu thì dao động thuộc dạng thứ 1; nếu chuyển dịch đổi dấu 1 lần thì dao động 

thuộc dạng thứ 2; nếu chuyển dịch đổi dấu 2 lần thì dao động theo dạng thứ 3 

 

 

Thông thường phần mềm sẽ tự động nhận dạng và chỉ định dao động theo các phương bằng cách kết 

hợp 2 quy tắc sau:  

 Mỗi phương chỉ có duy nhất 1 dao động ứng với mỗi dạng. Nghĩa là chỉ có 1 dao động dạng 

thứ 1, 1 dao động dạng thứ 2, và 1 dao động dạng thứ 3 theo mỗi phương 

 Ưu tiên khối lượng tham gia dao động lớn hơn để chỉ định dạng dao động theo phương đó 
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Ví dụ với dữ liệu như hình trên:  

 Mode ID = 1, có ID X và ID Y đều bằng 1, tuy nhiên Mass X = 61.9 > Mass Y = 3.9 do đó 

chọn Mode ID = 1 làm dạng dao động thứ 1 theo phương X. 

 Do đã có dạng thứ 1 theo phương X nên đối với phương X ta chỉ tìm tiếp dạng dao động thứ 

2 (có ID X = 2) 

7.3. Khoảng cách từ mặt đất đến mặt móng 

 

 

Sơ đồ kết cấu thường xây dựng tính từ mặt móng, cao độ chân cột vách không phải bao giờ cũng ở 

cao độ mặt đất; trong khi cao độ Z dùng để xác định hệ số K lại được tính từ mặt đất; do đó phần 

mềm cho phép người dùng nhập thông số khoảng cách từ mặt đất tới mặt móng để xử lý các số liệu 

trên tại ô nhập ở góc phía trên bên phải của phần mềm. 
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8. TÍNH TOÁN 

Click Tính toán trên thanh công cụ hoặc sử dụng phím tắt F5 

 

 

Chuyển qua các tab Kết quả tính toán thành phần Tĩnh và Kết quả tính toán thành phần Động 

để xem giá trị tương ứng 
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9. XUẤT KẾT QUẢ 

9.1. Xuất kết quả tính toán ra file Excel 

Click Xuất file Excel trên thanh công cụ 

 

 

Trong cửa sổ Chọn mẫu Excel, chọn mẫu mà bạn muốn trong danh sách sau đó click Hoàn thành. 

Cuối cùng chọn thư mục để xuất các file tính. 

 

 

9.2. Hiệu chỉnh mẫu file Excel 

Phần mềm mặc định mẫu file Excel là Default, đây là tên của thư mục chứa các mẫu chuẩn của phần 

mềm. Người dùng có thể hiệu chỉnh mẫu file có sẵn, hoặc tạo thêm các mẫu khác theo mong muốn. 

Để hiệu chỉnh mẫu file Excel, click Công cụ > Hiệu chỉnh mẫu Excel 

  

  

Trong thư mục Form, bạn sẽ thấy thư mục Default chứa các file Excel mặc định. Bạn có thể copy thư 

mục Default này và đổi tên thành một thư mục mới, tên thư mục mới này sẽ có mặt trong danh sách 

chọn mẫu file Excel khi bạn tiến hành xuất file. 

Mở các file Excel và hiệu chỉnh nội dung file: như thay đổi tiêu đề, chèn logo, thay đổi định dạng, 

font chữ v.v.. Lưu ý bạn chỉ được thêm dòng chứ không được bớt các dòng có sẵn, bạn cũng không 

được thay đổi số lượng cột, hay vị trí các ô (cột) mà phần mềm sẽ ghi dữ liệu lên đó.  
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10. NHẬP TẢI TRỌNG VÀO PHẦN MỀM ETABS 

Dữ liệu xuất file Excel phù hợp với quy tắc hiển thị trong mục khai báo tải trọng của Etabs, bạn chỉ 

cần quét chọn các giá trị tải trọng copy và paste vào trong cột khai báo tải trọng của Etabs khi sử 

dụng phương pháp khai báo tải trọng thông qua diaphragm 
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